Git GUI can create and overwrite files for which the user has write permission (j6t git-gui)

CVE-2025-46835
HIGH 8.5

En bref

Source
NVD
EPSS
EPSS 0.61 % · centile 49 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
GitHub_M
Statut NVD
Deferred

Description

Git GUI allows you to use the Git source control management tools via a GUI. When a user clones an untrusted repository and is tricked into editing a file located in a maliciously named directory in the repository, then Git GUI can create and overwrite files for which the user has write permission. This vulnerability is fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.1.

Faiblesses (CWE)

  • CWE-88 — Injection d'argument

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1HIGH 8.5CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:LGitHub_M
CVSS 3.1HIGH 8.5CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:LNVD · security-advisories@github.com (Secondary)

Références européennes

Avis du CERT-FR

Produits affectés

ProduitVersions
j6t · git-guiaffected < 2.43.7 ; affected >= 2.44.0, < 2.44.4 ; affected >= 2.45.0, < 2.45.4 ; affected >= 2.46.0, < 2.46.4 ; affected >= 2.47.0, < 2.47.3 ; affected >= 2.48.0, < 2.48.2

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD