Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only) (Apache Software Foundation Apache Cassandra)
En bref
- Source
- NVD
- EPSS
- EPSS 0.52 % · centile 44 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- apache
- Statut NVD
- Analyzed
Rechercher sur…
Description
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected. Users in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.
Faiblesses (CWE)
- CWE-267 — Privilege Defined With Unsafe Actions
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | CISA-ADP |
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
Avis
- GHSA-5c4f-pxmx-xcm4 — Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)
Références européennes
- ENISA EUVD · EUVD-2025-25767
- GCVE · GCVE-0-2025-26467
Configurations affectées (CPE NVD)
cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:*≥ 3.0.0 < 3.0.31cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:*≥ 3.11.0 < 3.11.18cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:*≥ 4.0.0 < 4.0.17cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:*≥ 4.1.0 < 4.1.8cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:*≥ 5.0.0 < 5.0.3
Produits affectés
| Produit | Versions |
|---|---|
| Apache Software Foundation · Apache Cassandra | affected 4.0.16 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |