Apache Lucene Replicator: Security Vulnerability in Lucene Replicator - Deserialization Issue (Apache Software Foundation Apache Lucene Replicator)

CVE-2024-45772
MEDIUM 5.1

En bref

Source
NVD
EPSS
EPSS 0.58 % · centile 48 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
apache
Statut NVD
Analyzed

Description

Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator. This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.

Faiblesses (CWE)

  • CWE-502 — Désérialisation de données non fiables

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1MEDIUM 5.1CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:Lapache
CVSS 3.1MEDIUM 5.1CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:LNVD · security@apache.org (Secondary)
CVSS 3.1HIGH 8.0CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HNVD · nvd@nist.gov (Primary)

Avis

Références européennes

Avis du CERT-FR

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
Apache Software Foundation · Apache Lucene Replicatoraffected 4.4.0 < 9.12.0

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD