Git's protections for cloning untrusted repositories can be bypassed (git git)
En bref
- Source
- NVD
- EPSS
- EPSS 1.03 % · centile 64 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Analyzed
Rechercher sur…
Description
Git is a revision control system. The Git project recommends to avoid working in untrusted repositories, and instead to clone it first with `git clone --no-local` to obtain a clean copy. Git has specific protections to make that a safe operation even with an untrusted source repository, but vulnerabilities allow those protections to be bypassed. In the context of cloning local repositories owned by other users, this vulnerability has been covered in CVE-2024-32004. But there are circumstances where the fixes for CVE-2024-32004 are not enough: For example, when obtaining a `.zip` file containing a full copy of a Git repository, it should not be trusted by default to be safe, as e.g. hooks could be configured to run within the context of that repository. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid using Git in repositories that have been obtained via archives from untrusted sources.
Faiblesses (CWE)
- CWE-22 — Traversée de répertoire
Références
- https://github.com/git/git/security/advisories/GHSA-vm9j-46j9-qvq4
- https://github.com/git/git/commit/7b70e9efb18c2cc3f219af399bd384c5801ba1d7
- https://git-scm.com/docs/git#_security
- https://git-scm.com/docs/git-clone
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/S4CK4IYTXEOBZTEM5K3T6LWOIZ3S44AR/
- http://www.openwall.com/lists/oss-security/2024/05/14/2
- https://lists.debian.org/debian-lts-announce/2024/06/msg00018.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00009.html
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.4 | CVSS:3.1/AV:P/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H | GitHub_M |
| CVSS 3.1 | HIGH 7.3 | CVSS:3.1/AV:P/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 7.8 | CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H | NVD · nvd@nist.gov (Primary) |
Références européennes
- ENISA EUVD · EUVD-2024-30280
- GCVE · GCVE-0-2024-32465
Avis du CERT-FR
- CERTFR-2025-AVI-0304 — Multiples vulnérabilités dans les produits Juniper Networks · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0741 — Multiples vulnérabilités dans Juniper Secure Analytics · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0646 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*< 2.39.4cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*≥ 2.40.0 < 2.40.2cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*≥ 2.42.0 < 2.42.2cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*≥ 2.43.0 < 2.43.4cpe:2.3:a:git-scm:git:2.41.0:*:*:*:*:*:*:*cpe:2.3:a:git-scm:git:2.44.0:*:*:*:*:*:*:*cpe:2.3:a:git-scm:git:2.45.0:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| git · git | affected = 2.45.0 ; affected = 2.44.0 ; affected >= 2.43.0, < 2.43.4 ; affected >= 2.42.0, < 2.42.2 ; affected = 2.41.0 ; affected >= 2.40.0, < 2.40.2 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |