Apache Airflow: Ignored Airflow Permissions (Apache Software Foundation Apache Airflow)
At a glance
- Source
- NVD
- EPSS
- EPSS 1.34 % · percentile 71 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- apache
- NVD status
- Modified
Description
Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access. Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability
Weaknesses (CWE)
- CWE-281 — Improper Preservation of Permissions
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N | CISA-ADP |
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
Advisories
- GHSA-h574-6646-vfxx — Apache Airflow: Ignored Airflow Permission
- PYSEC-2024-46 — Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variabl
European references
- ENISA EUVD · EUVD-2024-0007
- GCVE · GCVE-0-2024-28746
Affected configurations (NVD CPE)
cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*≥ 2.8.0 < 2.8.3
Affected products
| Product | Versions |
|---|---|
| Apache Software Foundation · Apache Airflow | affected 2.8.0 < 2.8.3 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |