Parse Server literalizeRegexPart SQL Injection (parse-community parse-server)

CVE-2024-27298
CRITICAL 10.0

At a glance

Source
NVD
EPSS
EPSS 1.03 % · percentile 64 ()
State
PUBLISHED
Published
Updated
Assigner
GitHub_M
NVD status
Analyzed

Description

parse-server is a Parse Server for Node.js / Express. This vulnerability allows SQL injection when Parse Server is configured to use the PostgreSQL database. The vulnerability has been fixed in 6.5.0 and 7.0.0-alpha.20.

Weaknesses (CWE)

  • CWE-89 — Improper Neutralization of Special Elements used in an SQL Command

References

Scores

VersionScoreVectorScored by
CVSS 3.1CRITICAL 10.0CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:NGitHub_M
CVSS 3.1CRITICAL 10.0CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:NNVD · security-advisories@github.com (Secondary)

Advisories

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
parse-community · parse-serveraffected < 6.5.0 ; affected >= 7.0.0-alpha.1, < 7.0.0-alpha.20

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD