containerd affected by a local privilege escalation via wide permissions on CRI directory (containerd containerd)
At a glance
- Source
- NVD
- EPSS
- EPSS 0.17 % · percentile 6 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Analyzed
Description
containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.
Weaknesses (CWE)
- CWE-279 — Incorrect Execution-Assigned Permissions
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.3 | CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H | GitHub_M |
| CVSS 3.1 | HIGH 7.3 | CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 7.8 | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | NVD · nvd@nist.gov (Primary) |
Advisories
- GHSA-pwhc-rpq9-4c8w — containerd affected by a local privilege escalation via wide permissions on CRI directory
- GO-2025-4100 — containerd affected by a local privilege escalation via wide permissions on CRI directory in github.com/containerd/containerd
European references
- ENISA EUVD · EUVD-2024-22942
- GCVE · GCVE-0-2024-25621
CERT-FR advisories
- CERTFR-2026-AVI-1385 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0249 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2025-AVI-1129 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2025-AVI-1036 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:*< 1.7.29cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:*≥ 2.0.0 < 2.0.7cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:*≥ 2.1.0 < 2.1.5cpe:2.3:a:linuxfoundation:containerd:2.2.0:beta0:*:*:*:*:*:*cpe:2.3:a:linuxfoundation:containerd:2.2.0:beta1:*:*:*:*:*:*cpe:2.3:a:linuxfoundation:containerd:2.2.0:beta2:*:*:*:*:*:*cpe:2.3:a:linuxfoundation:containerd:2.2.0:rc0:*:*:*:*:*:*cpe:2.3:a:linuxfoundation:containerd:2.2.0:rc1:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| containerd · containerd | affected < 1.7.29 ; affected >= 2.0.0-beta.0, < 2.0.7 ; affected >= 2.1.0-beta.0, < 2.1.5 ; affected >= 2.2.0-beta.0, < 2.2.0 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |