Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository (Apache Software Foundation Apache Camel)

CVE-2024-22369
HIGH 7.8

At a glance

Source
NVD
EPSS
EPSS 0.75 % · percentile 55 ()
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Analyzed

Description

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Weaknesses (CWE)

  • CWE-502 — Deserialization of Untrusted Data

References

Scores

VersionScoreVectorScored by
CVSS 3.1HIGH 7.8CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HCISA-ADP
CVSS 3.1HIGH 7.8CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

Advisories

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation · Apache Camelaffected 3.0.0 < 3.21.4 ; affected 3.22.0 < 3.22.1 ; affected 4.0.0 < 4.0.4 ; affected 4.1.0 < 4.4.0

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD