Apache Airflow: Improper access control vulnerability in the "List dag warnings" feature (Apache Software Foundation Apache Airflow)

CVE-2023-42780
MEDIUM 6.5

At a glance

Source
NVD
EPSS
EPSS 1.44 % Β· percentile 73 ()
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Modified

Description

Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAGs. It would reveal the dag_ids and the stack-traces of import errors for those DAGs with import errors. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Weaknesses (CWE)

  • CWE-200 β€” Exposure of Sensitive Information to an Unauthorized Actor

References

Scores

VersionScoreVectorScored by
CVSS 3.1MEDIUM 6.5CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NNVD Β· nvd@nist.gov (Primary)

Advisories

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation Β· Apache Airflowaffected 0 < 2.7.2

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST β€” attribution requested
ENISA EUVDENISA β€” reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain β€” this product uses data from the NVD API but is not endorsed or certified by the NVD