TransparentUpgradeableProxy clashing selector calls may not be delegated in @openzeppelin/contracts (OpenZeppelin openzeppelin-contracts)
At a glance
- Source
- NVD
- EPSS
- EPSS 0.81 % · percentile 57 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
OpenZeppelin Contracts is a library for secure smart contract development. A function in the implementation contract may be inaccessible if its selector clashes with one of the proxy's own selectors. Specifically, if the clashing function has a different signature with incompatible ABI encoding, the proxy could revert while attempting to decode the arguments from calldata. The probability of an accidental clash is negligible, but one could be caused deliberately and could cause a reduction in availability. The issue has been fixed in version 4.8.3. As a workaround if a function appears to be inaccessible for this reason, it may be possible to craft the calldata such that ABI decoding does not fail at the proxy and the function is properly proxied through.
Weaknesses (CWE)
- CWE-436 — Interpretation Conflict
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | GitHub_M |
| CVSS 3.1 | MEDIUM 5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | MEDIUM 5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | NVD · nvd@nist.gov (Primary) |
Advisories
- GHSA-mx2q-35m2-x2rh — OpenZeppelin Contracts TransparentUpgradeableProxy clashing selector calls may not be delegated
European references
- ENISA EUVD · EUVD-2023-1359
- GCVE · GCVE-0-2023-30541
Affected configurations (NVD CPE)
cpe:2.3:a:openzeppelin:contracts:*:*:*:*:*:node.js:*:*≥ 3.2.0 < 4.8.3cpe:2.3:a:openzeppelin:contracts_upgradeable:*:*:*:*:*:node.js:*:*≥ 3.2.0 < 4.8.3
Affected products
| Product | Versions |
|---|---|
| OpenZeppelin · openzeppelin-contracts | affected @openzeppelin/contracts: >= 3.2.0, < 4.8.3 ; affected @openzeppelin/contracts-upgradeable: >=3.2.0, <4.8.3 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |