Git vulnerable to Remote Code Execution via Heap overflow in `git shell` (git git)
At a glance
- Source
- NVD
- EPSS
- EPSS 3.99 % · percentile 91 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
Git is an open source, scalable, distributed revision control system. `git shell` is a restricted login shell that can be used to implement Git's push/pull functionality via SSH. In versions prior to 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4, the function that splits the command arguments into an array improperly uses an `int` to represent the number of entries in the array, allowing a malicious actor to intentionally overflow the return value, leading to arbitrary heap writes. Because the resulting array is then passed to `execv()`, it is possible to leverage this attack to gain remote code execution on a victim machine. Note that a victim must first allow access to `git shell` as a login shell in order to be vulnerable to this attack. This problem is patched in versions 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4 and users are advised to upgrade to the latest version. Disabling `git shell` access via remote logins is a viable short-term workaround.
Weaknesses (CWE)
References
- https://github.com/git/git/security/advisories/GHSA-rjr6-wcq6-83p6
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UKFHE4KVD7EKS5J3KTDFVBEKU3CLXGVV/
- https://support.apple.com/kb/HT213496
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OHNO2FB55CPX47BAXMBWUBGWHO6N6ZZH/
- http://seclists.org/fulldisclosure/2022/Nov/1
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C7B6JPKX5CGGLAHXJVQMIZNNEEB72FHD/
- https://lists.debian.org/debian-lts-announce/2022/12/msg00025.html
- https://security.gentoo.org/glsa/202312-15
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.5 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H | GitHub_M |
| CVSS 3.1 | HIGH 8.5 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H | NVD · nvd@nist.gov (Primary) |
European references
- ENISA EUVD · EUVD-2022-41771
- GCVE · GCVE-0-2022-39260
CERT-FR advisories
- CERTFR-2024-AVI-0119 — Multiples vulnérabilités dans les produits Siemens · cert.ssi.gouv.fr
- CERTFR-2022-AVI-983 — Multiples vulnérabilités dans Apple Xcode · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*< 2.30.6cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*≥ 2.31.0 < 2.31.5cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*≥ 2.32.0 < 2.32.4cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*≥ 2.33.0 < 2.33.5cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*≥ 2.34.0 < 2.34.5cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*≥ 2.35.0 < 2.35.5cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*≥ 2.36.0 < 2.36.3cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:*≥ 2.37.0 < 2.37.4cpe:2.3:a:git-scm:git:2.38.0:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:*cpe:2.3:a:apple:xcode:*:*:*:*:*:*:*:*< 14.1cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| git · git | affected < 2.30.6 ; affected > 2.31.0, < 2.31.5 ; affected > 2.32.0, < 2.32.4 ; affected > 2.33.0, < 2.33.5 ; affected > 2.34.0, < 2.34.5 ; affected > 2.34.0, < 2.35.5 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |