CVE-2022-36023
Remote denial of service in Hyperledger Fabric Gateway
HIGH 7.0
At a glance
- Source
- NVD
- EPSS
- EPSS 1.13 % · percentile 66 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
Weaknesses (CWE)
- CWE-20 — Improper Input Validation
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.0 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H | GitHub_M |
| CVSS 3.1 | HIGH 7.0 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | MEDIUM 5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | NVD · nvd@nist.gov (Primary) |
Advisories
- GHSA-qj6r-fhrc-jj5r — Remote denial of service in Hyperledger Fabric Gateway
European references
- ENISA EUVD · EUVD-2022-7152
- GCVE · GCVE-0-2022-36023
Affected configurations (NVD CPE)
cpe:2.3:a:hyperledger:fabric:*:*:*:*:*:*:*:*< 2.4.6
Affected products
| Product | Versions |
|---|---|
| hyperledger · fabric | affected < 2.4.6 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |