Moodle
En bref
- Source
- NVD
- EPSS
- EPSS 4.84 % · centile 92 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- fedora
- Statut NVD
- Modified
Description
A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.
Faiblesses (CWE)
- CWE-79 — Injection de code indirecte (XSS)
Références
- https://bugzilla.redhat.com/show_bug.cgi?id=2106277
- https://moodle.org/mod/forum/discuss.php?d=436460
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72299
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V/
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-62wh-m4jr-233r — Moodle LTI module reflected XSS risk
Références européennes
- ENISA EUVD · EUVD-2022-6256
- GCVE · GCVE-0-2022-35653
Avis du CERT-FR
- CERTFR-2022-AVI-653 — Multiples vulnérabilités dans Moodle · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*≥ 3.9.0 < 3.9.15cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*≥ 3.11.0 < 3.11.8cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:*cpe:2.3:a:moodle:moodle:4.0.0:beta:*:*:*:*:*:*cpe:2.3:a:moodle:moodle:4.0.0:rc1:*:*:*:*:*:*cpe:2.3:a:moodle:moodle:4.0.0:rc2:*:*:*:*:*:*cpe:2.3:a:moodle:moodle:4.0.0:rc3:*:*:*:*:*:*cpe:2.3:a:moodle:moodle:4.0.0:rc4:*:*:*:*:*:*cpe:2.3:a:moodle:moodle:4.0.1:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| Moodle | affected Fixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |