https://github.com/rails/rails
En bref
- Source
- NVD
- EPSS
- EPSS 4.87 % · centile 92 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- hackerone
- Statut NVD
- Modified
Rechercher sur…
Description
The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service vulnerability in the Token Authentication logic in Action Controller due to a too permissive regular expression. Impacted code uses `authenticate_or_request_with_http_token` or `authenticate_with_http_token` for request authentication.
Faiblesses (CWE)
- CWE-400 — Consommation de ressources non maîtrisée (déni de service)
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 5.0 | AV:N/AC:L/Au:N/C:N/I:N/A:P | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-7wjx-3g7j-8584 — Possible DoS Vulnerability in Action Controller Token Authentication
Références européennes
- ENISA EUVD · EUVD-2021-1009
- GCVE · GCVE-0-2021-22904
Avis du CERT-FR
- CERTFR-2021-AVI-352 — Multiples vulnérabilités dans Ruby on Rails · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*< 5.2.4.6cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*≥ 5.2.5 < 5.2.6cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*≥ 6.0.0 < 6.0.3.7cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:*≥ 6.1.0 < 6.1.3.2
Produits affectés
| Produit | Versions |
|---|---|
| https://github.com/rails/rails | affected Fixed in 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |