XSS in Dijit Editor's LinkDialog plugin (Dojo dijit)
At a glance
- Source
- NVD
- EPSS
- EPSS 1.18 % · percentile 68 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
In Dijit before versions 1.11.11, and greater than or equal to 1.12.0 and less than 1.12.9, and greater than or equal to 1.13.0 and less than 1.13.8, and greater than or equal to 1.14.0 and less than 1.14.7, and greater than or equal to 1.15.0 and less than 1.15.4, and greater than or equal to 1.16.0 and less than 1.16.3, there is a cross-site scripting vulnerability in the Editor's LinkDialog plugin. This has been fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3.
Weaknesses (CWE)
- CWE-79 — Improper Neutralization of Input During Web Page Generation
References
- https://github.com/dojo/dijit/security/advisories/GHSA-cxjc-r2fp-7mq6
- https://github.com/dojo/dijit/commit/462bdcd60d0333315fe69ab4709c894d78f61301
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://security.netapp.com/advisory/ntap-20201023-0003/
- https://lists.debian.org/debian-lts-announce/2023/01/msg00030.html
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | LOW 3.7 | CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N | GitHub_M |
| CVSS 3.1 | LOW 3.7 | CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | MEDIUM 5.4 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | LOW 3.5 | AV:N/AC:M/Au:S/C:N/I:P/A:N | NVD · nvd@nist.gov (Primary) |
Advisories
- GHSA-cxjc-r2fp-7mq6 — Cross-site Scripting in dijit editor's LinkDialog plugin
European references
- ENISA EUVD · EUVD-2020-0482
- GCVE · GCVE-0-2020-4051
CERT-FR advisories
- CERTFR-2024-AVI-0330 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0214 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2022-AVI-928 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2020-AVI-664 — Multiples vulnérabilités dans Oracle MySQL · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:openjsf:dijit:*:*:*:*:*:*:*:*< 1.11.11cpe:2.3:a:openjsf:dijit:*:*:*:*:*:*:*:*≥ 1.12.0 < 1.12.9cpe:2.3:a:openjsf:dijit:*:*:*:*:*:*:*:*≥ 1.13.0 < 1.13.8cpe:2.3:a:openjsf:dijit:*:*:*:*:*:*:*:*≥ 1.14.0 < 1.14.7cpe:2.3:a:openjsf:dijit:*:*:*:*:*:*:*:*≥ 1.15.0 < 1.15.4cpe:2.3:a:openjsf:dijit:*:*:*:*:*:*:*:*≥ 1.16.0 < 1.16.3cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:*cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:windows:*:*cpe:2.3:a:netapp:oncommand_insight:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| Dojo · dijit | affected < 1.11.11 ; affected >= 1.12.0, < 1.12.9 ; affected >= 1.13.0, < 1.13.8 ; affected >= 1.14.0, < 1.14.7 ; affected >= 1.15.0, < 1.15.4 ; affected >= 1.16.0, < 1.16.3 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |