Cross-site scripting in stats method (object cache) in WordPress (WordPress WordPress)
At a glance
- Source
- NVD
- EPSS
- EPSS 2.13 % · percentile 82 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
In affected versions of WordPress, a vulnerability in the stats() method of class-wp-object-cache.php can be exploited to execute cross-site scripting (XSS) attacks. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Weaknesses (CWE)
- CWE-79 — Improper Neutralization of Input During Web Page Generation
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 5.8 | CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N | GitHub_M |
| CVSS 3.1 | MEDIUM 5.8 | CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | MEDIUM 6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 4.3 | AV:N/AC:M/Au:N/C:N/I:P/A:N | NVD · nvd@nist.gov (Primary) |
European references
- ENISA EUVD · EUVD-2020-3414
- GCVE · GCVE-0-2020-11029
Affected configurations (NVD CPE)
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 3.7 < 3.7.33cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 3.8 < 3.8.33cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 3.9 < 3.9.31cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.0 < 4.0.30cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.1 < 4.1.30cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.2 < 4.2.27cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.3 < 4.3.23cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.4 < 4.4.22cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.5 < 4.5.21cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.6 < 4.6.18cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.7 < 4.7.17cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.8 < 4.8.13cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.9 < 4.9.14cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.0 < 5.0.9cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.1 < 5.1.5cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.2 < 5.2.6cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.3 < 5.3.3cpe:2.3:a:wordpress:wordpress:5.4:*:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| WordPress · WordPress | affected >= 5.4.0, < 5.4.1 ; affected >= 5.3.0, < 5.3.3 ; affected >= 5.2.0, < 5.2.6 ; affected >= 5.1.0, < 5.1.5 ; affected >= 5.0.0, < 5.0.9 ; affected >= 4.9.0, < 4.9.14 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |