CVE-2020-11027
Password reset links invalidation issue in WordPress
MEDIUM 6.1
At a glance
- Source
- NVD
- EPSS
- EPSS 13.63 % · percentile 96 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
In affected versions of WordPress, a password reset link emailed to a user does not expire upon changing the user password. Access would be needed to the email account of the user by a malicious party for successful execution. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Weaknesses (CWE)
- CWE-672 — Operation on a Resource after Expiration or Release
- CWE-640 — Weak Password Recovery Mechanism for Forgotten Password
References
- https://wordpress.org/support/wordpress-version/version-5-4-1/#security-updates
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-ww7v-jg8c-q6jw
- https://www.debian.org/security/2020/dsa-4677
- https://lists.debian.org/debian-lts-announce/2020/05/msg00011.html
- http://packetstormsecurity.com/files/173034/WordPress-Theme-Medic-1.0.0-Weak-Password-Recovery-Mechanism.html
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 6.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N | GitHub_M |
| CVSS 3.1 | MEDIUM 6.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 5.5 | AV:N/AC:L/Au:S/C:P/I:P/A:N | NVD · nvd@nist.gov (Primary) |
European references
- ENISA EUVD · EUVD-2020-3412
- GCVE · GCVE-0-2020-11027
Affected configurations (NVD CPE)
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 3.7 < 3.7.33cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 3.8 < 3.8.33cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 3.9 < 3.9.31cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.0 < 4.0.30cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.1 < 4.1.30cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.2 < 4.2.27cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.3 < 4.3.23cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.4 < 4.4.22cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.5 < 4.5.21cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.6 < 4.6.18cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.7 < 4.7.17cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.8 < 4.8.13cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.9 < 4.9.14cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.0 < 5.0.9cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.1 < 5.1.5cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.2 < 5.2.6cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.3 < 5.3.3cpe:2.3:a:wordpress:wordpress:5.4:*:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| WordPress · WordPress | affected >= 5.4.0, < 5.4.1 ; affected >= 5.3.0, < 5.3.3 ; affected >= 5.2.0, < 5.2.6 ; affected >= 5.1.0, < 5.1.5 ; affected >= 5.0.0, < 5.0.9 ; affected >= 4.9.0, < 4.9.14 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |