python-apt downloads from untrusted sources (Canonical Python-apt)

CVE-2019-15796
MEDIUM 4.7

En bref

Source
NVD
EPSS
EPSS 0.51 % · centile 43 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
canonical
Statut NVD
Modified

Description

Python-apt doesn't check if hashes are signed in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py or in `_fetch_archives()` of apt/cache.py in version 1.9.3ubuntu2 and earlier. This allows downloads from unsigned repositories which shouldn't be allowed and has been fixed in verisions 1.9.5, 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

Faiblesses (CWE)

  • CWE-287 — Authentification incorrecte
  • CWE-347 — Vérification incorrecte d'une signature cryptographique

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1MEDIUM 4.7CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:Ncanonical
CVSS 3.1MEDIUM 4.7CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:NNVD · security@ubuntu.com (Secondary)
CVSS 3.1MEDIUM 4.7CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:NNVD · nvd@nist.gov (Primary)
CVSS 2.0LOW 2.6AV:N/AC:H/Au:N/C:N/I:P/A:NNVD · nvd@nist.gov (Primary)

Avis

Références européennes

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
Canonical · Python-aptaffected 0.8.3 < 0.8.3ubuntu7.5 ; affected 0.9.3.5 < 0.9.3.5ubuntu3+esm2 ; affected 1.1.0 < 1.1.0~beta1ubuntu0.16.04.7 ; affected 1.6.5 < 1.6.5ubuntu0.1 ; affected 1.9.0 < 1.9.0ubuntu1.2 ; affected 1.9.5 < 1.9.5

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD