Red Hat ansible
En bref
- Source
- NVD
- EPSS
- EPSS 1.77 % · centile 78 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- redhat
- Statut NVD
- Modified
Description
A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.
Faiblesses (CWE)
- CWE-200 — Exposition d'informations sensibles à un acteur non autorisé
Références
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10156
- https://github.com/ansible/ansible/pull/57188
- https://lists.debian.org/debian-lts-announce/2019/09/msg00016.html
- https://access.redhat.com/errata/RHSA-2019:3744
- https://access.redhat.com/errata/RHSA-2019:3789
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
- https://www.debian.org/security/2021/dsa-4950
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.0 | MEDIUM 4.6 | CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N | redhat |
| CVSS 3.1 | MEDIUM 5.4 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 3.0 | MEDIUM 4.6 | CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N | NVD · secalert@redhat.com (Secondary) |
| CVSS 2.0 | MEDIUM 5.5 | AV:N/AC:L/Au:S/C:P/I:P/A:N | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-grgm-pph5-j5h7 — Exposure of Sensitive Information to an Unauthorized Actor in ansible
- PYSEC-2019-2 — A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosu
Références européennes
- ENISA EUVD · EUVD-2019-0006
- GCVE · GCVE-0-2019-10156
Configurations affectées (CPE NVD)
cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*< 2.6.18cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*≥ 2.7.0 < 2.7.12cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*≥ 2.8.0 < 2.8.2cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:*cpe:2.3:a:redhat:openstack:14:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| Red Hat · ansible | affected fixed in 2.6.18 ; affected fixed in 2.7.12 ; affected fixed in 2.8.2 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |