Atlassian Bamboo

CVE-2018-5224
HIGH 8.8

En bref

Source
NVD
EPSS
EPSS 2.67 % · centile 86 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
atlassian
Statut NVD
Modified

Description

Bamboo did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan in Bamboo that has a non-linked Mercurial repository, or create a plan in Bamboo either globally or in a project using Bamboo Specs can can execute code of their choice on systems that run a vulnerable version of Bamboo on the Windows operating system. All versions of Bamboo starting with 2.7.0 before 6.3.3 (the fixed version for 6.3.x) and from version 6.4.0 before 6.4.1 (the fixed version for 6.4.x) running on the Windows operating system are affected by this vulnerability.

Faiblesses (CWE)

  • CWE-20 — Validation d'entrée incorrecte

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.0HIGH 8.8CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HNVD · nvd@nist.gov (Primary)
CVSS 2.0HIGH 9.0AV:N/AC:L/Au:S/C:C/I:C/A:CNVD · nvd@nist.gov (Primary)

Références européennes

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
Atlassian · Bambooaffected 2.7.1 < unspecified ; affected unspecified < 6.3.3 ; affected 6.4.0 < unspecified ; affected unspecified < 6.4.1

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD