https://github.com/rails/rails

CVE-2018-16476
HIGH 7.5

At a glance

Source
NVD
EPSS
EPSS 2.86 % · percentile 87 ()
State
PUBLISHED
Published
Updated
Assigner
hackerone
NVD status
Modified

Description

A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.

Weaknesses (CWE)

  • CWE-284 — Improper Access Control
  • CWE-502 — Deserialization of Untrusted Data

References

Scores

VersionScoreVectorScored by
CVSS 3.0HIGH 7.5CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NNVD · nvd@nist.gov (Primary)
CVSS 2.0MEDIUM 5.0AV:N/AC:L/Au:N/C:P/I:N/A:NNVD · nvd@nist.gov (Primary)

Advisories

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
https://github.com/rails/railsaffected 4.2.0 up to and before 4.2.11 ; affected 4.2.0 up to and before 5.0.7.1 ; affected 4.2.0 up to and before 5.1.6.1 ; affected 4.2.0 up to and before 5.2.1.1

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD