Drupal.org Drupal Core
At a glance
- Source
- NVD
- EPSS
- EPSS 1.22 % Β· percentile 69 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- drupal
- NVD status
- Modified
Description
A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.
Weaknesses (CWE)
- CWE-79 β Improper Neutralization of Input During Web Page Generation
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.0 | MEDIUM 6.1 | CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N | NVD Β· nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 4.3 | AV:N/AC:M/Au:N/C:N/I:P/A:N | NVD Β· nvd@nist.gov (Primary) |
Advisories
- GHSA-5vpr-v24w-mmjj β Drupal cross site scripting vulnerability
European references
- ENISA EUVD Β· EUVD-2022-2662
- GCVE Β· GCVE-0-2017-6929
Affected configurations (NVD CPE)
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*β₯ 7.0 < 7.57cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*β₯ 8.0.0 < 8.4.0cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| Drupal.org Β· Drupal Core | affected 7.x versions before 7.57 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST β attribution requested |
| ENISA EUVD | ENISA β reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain β this product uses data from the NVD API but is not endorsed or certified by the NVD |