PYSEC-2026-772

OS Command Injection in Apache Airflow

At a glance

Published
Updated
CVE
CVE-2022-41131
Aliases
BIT-airflow-2022-41131, GHSA-cm43-f2pv-6v68
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Hive Provider, Apache Airflow allows an attacker to execute arbtrary commands in the task execution context, without write access to DAG files. This issue affects Hive Provider versions prior to 4.1.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case HIve Provider is installed (Hive Provider 4.1.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the HIve Provider version 4.1.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version that has lower version of the Hive Provider installed).

Affected packages

PackageVersions
PyPI · apache-airflow-providers-apache-hiveintroduced 0, fixed 4.1.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database