PYSEC-2026-4

At a glance

Published
Updated
CVE
CVE-2026-8212
Aliases
BIT-gdal-2026-8212, GHSA-r5m4-5vww-w9f5
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Description

A flaw has been found in OSGeo gdal up to 3.13.0dev-4. Affected by this vulnerability is the function SWSDfldsrch of the file frmts/hdf4/hdf-eos/SWapi.c. Executing a manipulation can lead to heap-based buffer overflow. The attack requires local access. The exploit has been published and may be used. Upgrading to version 3.13.0RC1 addresses this issue. This patch is called 3e04c0385630e4d42517046d9a4967dfccfeb7fd. The affected component should be upgraded.

Affected packages

PackageVersions
PyPI · gdal

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database