PYSEC-2026-451
pgAdmin 4 Vulnerable to Remote Code Execution
At a glance
- Published
- Updated
- CVE
- CVE-2025-2945
- Aliases
- GHSA-g73c-fw68-pwx3
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Description
Remote Code Execution security vulnerability in pgAdmin 4 (Query Tool and Cloud Deployment modules). The vulnerability is associated with the 2 POST endpoints; /sqleditor/query_tool/download, where the query_commited parameter and /cloud/deploy endpoint, where the high_availability parameter is unsafely passed to the Python eval() function, allowing arbitrary code execution. This issue affects pgAdmin 4: before 9.2.
Affected packages
| Package | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 9.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-2945 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/8603 WEB
- https://github.com/pgadmin-org/pgadmin4/commit/75be0bc22d3d8d7620711835db817bd7c021007c WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
- https://pypi.org/project/pgadmin4 PACKAGE
- https://github.com/advisories/GHSA-g73c-fw68-pwx3 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |