PYSEC-2026-43

At a glance

Published
Updated
CVE
CVE-2025-14550
Aliases
BIT-django-2025-14550, GHSA-33mw-q7rj-mjwj
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

An issue was discovered in 6.0 before 6.0.2, 5.2 before 5.2.11, and 4.2 before 4.2.28. `ASGIRequest` allows a remote attacker to cause a potential denial-of-service via a crafted request with multiple duplicate headers. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Jiyong Yang for reporting this issue.

Affected packages

PackageVersions
PyPI · djangointroduced 4.2, fixed 4.2.28, introduced 5.2, fixed 5.2.11, introduced 6.0, fixed 6.0.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database