PYSEC-2026-42

En bref

Publiée
Mise à jour
CVE
CVE-2025-13473
Alias
BIT-django-2025-13473, GHSA-2mcm-79hx-8fxw
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N

Description

An issue was discovered in 6.0 before 6.0.2, 5.2 before 5.2.11, and 4.2 before 4.2.28. The `django.contrib.auth.handlers.modwsgi.check_password()` function for authentication via `mod_wsgi` allows remote attackers to enumerate users via a timing attack. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Stackered for reporting this issue.

Paquets affectés

PaquetVersions
PyPI · djangointroduced 4.2, fixed 4.2.28, introduced 5.2, fixed 5.2.11, introduced 6.0, fixed 6.0.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database