PYSEC-2026-4186
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-103241
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · vllm | introduced 0, fixed 0.27.0 |
Références
- https://gist.github.com/Yunzez/8e98d656aa667095b513161eb056d28e WEB
- https://github.com/vllm-project/vllm/ WEB
- https://github.com/vllm-project/vllm/releases/tag/v0.29.1rc0 ADVISORY
- https://vuldb.com/cve/CVE-2026-103241 ADVISORY
- https://vuldb.com/submit/956250 ADVISORY
- https://vuldb.com/vuln/411965 ADVISORY
- https://vuldb.com/vuln/411965/cti REPORT
- https://github.com/vllm-project/vllm/commit/3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9 FIX
- https://github.com/vllm-project/vllm/issues/50927 FIX
- https://github.com/vllm-project/vllm/pull/54303 FIX
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |