PYSEC-2026-380

Langflow Unauth RCE

At a glance

Published
Updated
CVE
CVE-2025-3248
Aliases
GHSA-rvqx-wpfh-mfx7, PYSEC-2025-36
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A

Description

Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.

Affected packages

PackageVersions
PyPI · langflow-baseintroduced 0, fixed 0.3.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database