PYSEC-2026-274

Apache Airflow Hive Provider vulnerable to Command Injection

At a glance

Published
Updated
CVE
CVE-2022-46421
Aliases
GHSA-rc58-qr9j-cpgw
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider before 5.0.0.

Affected packages

PackageVersions
PyPI · apache-airflow-providers-apache-hiveintroduced 0, fixed 5.0.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database