PYSEC-2026-271

Apache Airflow Hive Provider vulnerable to code injection

At a glance

Published
Updated
CVE
CVE-2023-28706
Aliases
GHSA-5cvg-9pp5-mxcj
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Apache Software Foundation's Apache Airflow Hive Provider before 6.0.0 is vulnerable to improper control of generation of code.

Affected packages

PackageVersions
PyPI · apache-airflow-providers-apache-hiveintroduced 0, fixed 6.0.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database