PYSEC-2026-270

OS Command Injection in Apache Airflow

At a glance

Published
Updated
CVE
CVE-2022-40189
Aliases
BIT-airflow-2022-40189, GHSA-rmf2-pwfq-h75j
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Pig Provider, Apache Airflow allows an attacker to control commands executed in the task execution context, without write access to DAG files. This issue affects Pig Provider versions prior to 4.0.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case Pig Provider is installed (Pig Provider 4.0.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the Pig Provider version 4.0.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.3.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database