PYSEC-2026-2525
OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere
At a glance
- Published
- Updated
- CVE
- CVE-2026-42510
- Aliases
- GHSA-wqpv-c3pp-3m58
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
Description
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
Affected packages
| Package | Versions |
|---|---|
| PyPI · ironic | introduced 0, fixed 35.0.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-42510 ADVISORY
- https://bugs.launchpad.net/ironic/+bug/2148331 WEB
- https://github.com/openstack/ironic PACKAGE
- https://security.openstack.org/ossa/OSSA-2026-008.html WEB
- http://www.openwall.com/lists/oss-security/2026/04/30/1 WEB
- https://pypi.org/project/ironic PACKAGE
- https://github.com/advisories/GHSA-wqpv-c3pp-3m58 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |