PYSEC-2026-2303

At a glance

Published
Updated
CVE
CVE-2026-55514
Aliases
GHSA-33cg-gxv8-3p8g
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Description

vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.

Affected packages

PackageVersions
PyPI · vllmintroduced 0.12.0, fixed 0.24.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database