PYSEC-2026-2156

At a glance

Published
Updated
CVE
CVE-2026-8088
Aliases
BIT-gdal-2026-8088, GHSA-j3f5-rw74-g4rv
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Description

A weakness has been identified in OSGeo gdal up to 3.13.0dev-4. The affected element is the function GDfieldinfo of the file frmts/hdf4/hdf-eos/GDapi.c. Executing a manipulation can lead to out-of-bounds read. The attack needs to be launched locally. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.13.0RC1 is sufficient to fix this issue. This patch is called a791f70f8eaec540974ec989ca6fb00266b7646c. The affected component should be upgraded.

Affected packages

PackageVersions
PyPI · gdalintroduced 0, fixed 3.13.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database