PYSEC-2026-2085

At a glance

Published
Updated
CVE
CVE-2026-12252
Aliases
GHSA-9r6g-266r-89x4
CVSS_V3
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Description

In nltk/nltk versions 3.9.3 and earlier, five Stanford interface classes (StanfordPOSTagger, StanfordNERTagger, StanfordParser, StanfordDependencyParser, and StanfordNeuralDependencyParser) are vulnerable to untrusted JAR code execution. These classes accept user-controllable JAR paths and execute them via the `java()` function, which invokes `subprocess.Popen()` without integrity verification. This vulnerability is identical to CVE-2026-0848, which was fixed for StanfordSegmenter by adding SHA256 verification. However, the fix was not applied to these additional classes, leaving them susceptible to arbitrary code execution when loading untrusted JAR files.

Affected packages

PackageVersions
PyPI · nltkintroduced 0, fixed 3.9.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database