PYSEC-2026-1777

pgAdmin Cross-site Scripting vulnerability in /settings/store API response json payload

At a glance

Published
Updated
CVE
CVE-2024-4216
Aliases
GHSA-xv64-8p4r-94gq
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

Description

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Affected packages

PackageVersions
PyPI · pgadmin4introduced 0, fixed 8.6

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database