PYSEC-2026-1773
pgAdmin has vulnerability in LDAP authentication mechanism that allows bypassing TLS certificate verification
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-12765
- Alias
- GHSA-g4r8-3qmh-pmch
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Description
pgAdmin <= 9.9 is affected by a vulnerability in the LDAP authentication mechanism allows bypassing TLS certificate verification.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 9.10 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2025-12765 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/9324 WEB
- https://github.com/pgadmin-org/pgadmin4/commit/09d2b7eeb0e330df73b1aef0cba57788fde52b6b WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
- https://pypi.org/project/pgadmin4 PACKAGE
- https://github.com/advisories/GHSA-g4r8-3qmh-pmch ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |