PYSEC-2026-1772
pgAdmin is affected by an LDAP injection vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2025-12764
- Aliases
- GHSA-cvf4-f829-762v
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
pgAdmin <= 9.9 is affected by an LDAP injection vulnerability in the LDAP authentication flow that allows an attacker to inject special LDAP characters in the username, causing the DC/LDAP server and the client to process an unusual amount of data DOS.
Affected packages
| Package | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 9.10 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-12764 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/9325 WEB
- https://github.com/pgadmin-org/pgadmin4/commit/09d2b7eeb0e330df73b1aef0cba57788fde52b6b WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
- https://pypi.org/project/pgadmin4 PACKAGE
- https://github.com/advisories/GHSA-cvf4-f829-762v ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |