PYSEC-2026-1768

pgAdmin is affected by a multi-factor authentication bypass vulnerability

At a glance

Published
Updated
CVE
CVE-2024-4215
Aliases
GHSA-2mvc-557g-5638
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L

Description

pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.

Affected packages

PackageVersions
PyPI · pgadmin4introduced 0, fixed 8.6

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database