PYSEC-2026-1767

pgAdmin Remote Code Execution (RCE) vulnerability

At a glance

Published
Updated
CVE
CVE-2024-3116
Aliases
GHSA-27jx-ffw8-xrqv
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

Description

pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.

Affected packages

PackageVersions
PyPI · pgadmin4introduced 0, fixed 8.5

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database