PYSEC-2026-14

At a glance

Published
Updated
CVE
CVE-2026-26929
Aliases
BIT-airflow-2026-26929, GHSA-4m3h-wp5w-5hqh
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Description

Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 3.0.0, fixed 3.1.8

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database