PYSEC-2026-1142

Airflow Sqoop Provider RCE Vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2023-27604
Alias
GHSA-g3m9-pr5m-4cvp
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Apache Airflow Sqoop Provider, versions before 4.0.0, is affected by a vulnerability that allows an attacker pass parameters with the connections, which makes it possible to implement RCE attacks via ‘sqoop import --connect’, obtain airflow server permissions, etc. The attacker needs to be logged in and have authorization (permissions) to create/edit connections. It is recommended to upgrade to a version that is not affected. This issue was reported independently by happyhacking-k, And Xie Jianming and LiuHui of Caiji Sec Team also reported it.

Paquets affectés

PaquetVersions
PyPI · apache-airflow-providers-apache-sqoopintroduced 0, fixed 4.0.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database