PYSEC-2025-42

At a glance

Published
Updated
CVE
CVE-2025-32444
Aliases
GHSA-hj4w-hm2g-p6w5
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.

Affected packages

PackageVersions
PyPI · vllmintroduced 0, fixed a5450f11c95847cf51a17207af9a3ca5ab569b2c ; introduced 0.6.5, fixed 0.8.5

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database