PYSEC-2025-36
At a glance
- Published
- Updated
- CVE
- CVE-2025-3248
- Aliases
- GHSA-rvqx-wpfh-mfx7, PYSEC-2026-380
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.
Affected packages
| Package | Versions |
|---|---|
| PyPI · langflow | introduced 0, fixed 1.3.0 |
References
- https://www.horizon3.ai/attack-research/disclosures/unsafe-at-any-speed-abusing-python-exec-for-unauth-rce-in-langflow-ai/ WEB
- https://github.com/langflow-ai/langflow/pull/6911 FIX
- https://github.com/langflow-ai/langflow/releases/tag/1.3.0 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |