PYSEC-2023-89

At a glance

Published
Updated
CVE
CVE-2023-35005
Aliases
BIT-airflow-2023-35005, GHSA-mjff-wv85-hmcj

Description

In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations. This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive. This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 2.5.0, fixed 2.6.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database