PYSEC-2023-265

At a glance

Published
Updated
CVE
CVE-2023-48291
Aliases
BIT-airflow-2023-48291, GHSA-8f57-wcmg-4jmh
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Description

Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't. This is a missing fix for CVE-2023-42792 in Apache Airflow 2.7.2  Users of Apache Airflow are strongly advised to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.8.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database