PYSEC-2022-43017
At a glance
- Published
- Updated
- CVE
- CVE-2022-40898
- Aliases
- GHSA-qwmp-2cf2-g9g6
Description
An issue discovered in Python Packaging Authority (PyPA) Wheel 0.37.1 and earlier allows remote attackers to cause a denial of service via attacker controlled input to wheel cli.
Affected packages
| Package | Versions |
|---|---|
| PyPI · wheel | introduced 0, fixed 0.38.1 |
References
- https://pypi.org/project/wheel/ PACKAGE
- https://github.com/pypa/wheel/blob/main/src/wheel/wheelfile.py#L18 WEB
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/ EVIDENCE
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/ ADVISORY
- https://github.com/advisories/GHSA-qwmp-2cf2-g9g6 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |