PYSEC-2022-42976

At a glance

Published
Updated
CVE
CVE-2022-31777
Aliases
BIT-spark-2022-31777, GHSA-43xg-8wmj-cw8h

Description

A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

Affected packages

PackageVersions
PyPI · pysparkintroduced 0, fixed 3.2.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database