PYSEC-2021-124

En bref

Publiée
Mise à jour
CVE
CVE-2021-20191
Alias
GHSA-8f4m-hccc-8qph

Description

A flaw was found in ansible. Credentials, such as secrets, are being disclosed in console log by default and not protected by no_log feature when using those modules. An attacker can take advantage of this information to steal those credentials. The highest threat from this vulnerability is to data confidentiality. Versions before ansible 2.9.18 are affected.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 0, fixed 2.8.19, introduced 2.9.0, fixed 2.9.18, introduced 2.10.0, fixed 2.10.7

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database